hns - 日記自動生成システム - Version 2.19.9

先月 2012年03月 来月
1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
Namazu for hns による簡易全文検索
詳しくは 詳細指定/ヘルプを参照して下さい
検索式:

2012年03月06日(火) 旧暦 [n年日記] [更新:"2012/03/06 21:36:47"]

#1 [pkgsrc][emacs][flim] Cannot open load file: advice

The problem I had before 2012/02/01 and 2011/02/28 .
===> Building for flim-1.14.9nb1
/usr/pkg/bin/emacs -batch -q -no-site-file -l FLIM-MK -f compile-flim NONE NONE  NONE
Warning: Could not find simple.el nor simple.elc
Loading /export/pkgsrc/devel/flim/work/flim-1.14.9/FLIM-CFG...
Loading /export/pkgsrc/devel/flim/work/flim-1.14.9/FLIM-ELS...
Cannot open load file: advice
*** Error code 255
Todays patch is here.

The problem is that

  • To build flim correctly, advice.el should be found.
  • It depends on the path installed emacs version.
  • But pkgsrc build assumes it is the same as pkgsrc/editors or wip/emacs-current (?) directory. Those may not be the same. My sample shows:
     * EMACS_VERSION_MAJOR = 24
     * EMACS_VERSION_MICRO = 90
     * EMACS_VERSION_MINOR = 0
    
    while pkg_info says:
    rf@makoto 21:31:43/120306(..devel/flim)% pkg_info -e emacs      
    emacs-24.0.92nb20111208
    
    which is not the same shown above.
* EMACS_VERSION_MICRO = 90
comes from emacs-snapshot. (With some reason, it is consistent).



最近の日記
2020年02月21日
size of the packages (NetBSD/amd64 9.0RC2) 48 GB
2020年02月08日
concrete5 and php 7.2
2020年01月13日
Hellow world on R
2020年01月05日
Certificate renewed.
2019年12月31日
graphics/adapta-gtk-theme-3.95.0.11nb2
以上、1 日分です。
タイトル一覧
カテゴリ分類
Powered by hns-2.19.9, HyperNikkiSystem Project

Count.cgi (since 2000/02/05)