hns - 日記自動生成システム - Version 2.19.9

先月 2011年01月 来月
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31
Namazu for hns による簡易全文検索
詳しくは 詳細指定/ヘルプを参照して下さい
検索式:

2011年01月22日() 旧暦 [n年日記] [更新:"2011/01/22 18:08:58"]

#1 [pkgsrc] png-1.4.5 to 1.5.1 issue

今机上機として使っている ML-115 (hostname modena) は、最近全て新しく入直したつもりのもの。
H/W    ML-115
OS NetBSD/amd64 5.1
pkgsrc pksrc-2010Q4 の後の 1/17 日頃 cvs update -dPA したもの
  • pkgsrc/*/*/work は全て消して
  • cvs update -dPA をして
  • pkg_delete -rR png
をしておいてから、自分用 meta-pkgs を用意したつもり。
でも ImageMagick も入っていて、(まだ png-1.5.1 には)非対応のはずなのに変だな、と思ったら 例えば display は、しっかり libpng14.so を参照している。どうして、そうなったのかな。
多分 pkg_delete が完全には消してくれなかったのが一番可能性が高い。

#2 [pkgsrc] pkg_delete -r -R -A

古い機械があったので、試して見た。-n を付けると、何を消すか 表示して、実際には消さない。下のを見るとこういう時 (何かの版が上って、それに依存しているものを入替える時)には -rR を使うのが良いらしいと思う。
pts/0:makoto@serv 17:49:57/110122(...net/mrtg)> pkg_delete -n jpeg
Package `jpeg-7' is still required by other packages:
        jasper-1.900.1nb4
        tiff-3.9.2
        lcms-1.18.0.1nb1

pts/0:makoto@serv 17:50:15/110122(...net/mrtg)> pkg_delete -nrR  jpeg
Attempting to delete package `ImageMagick-6.5.7.9'
Attempting to delete package `lcms-1.18.0.1nb1'
Attempting to delete package `tiff-3.9.2'
Attempting to delete package `jasper-1.900.1nb4'
Attempting to delete package `jpeg-7'
Attempting to delete package `libltdl-2.2.6b'
Attempting to delete package `png-1.2.41'

pts/0:makoto@serv 17:50:26/110122(...net/mrtg)> pkg_delete -nr jpeg
Attempting to delete package `ImageMagick-6.5.7.9'
Attempting to delete package `lcms-1.18.0.1nb1'
Attempting to delete package `tiff-3.9.2'
Attempting to delete package `jasper-1.900.1nb4'
Attempting to delete package `jpeg-7'

pts/0:makoto@serv 17:50:47/110122(...net/mrtg)> pkg_delete -nR  jpeg
Package `jpeg-7' is still required by other packages:
        jasper-1.900.1nb4
        tiff-3.9.2
        lcms-1.18.0.1nb1

pts/0:makoto@serv 17:51:01/110122(...net/mrtg)> pkg_delete -nA  jpeg
Package `jpeg-7' is still required by other packages:
        jasper-1.900.1nb4
        tiff-3.9.2
        lcms-1.18.0.1nb1



最近の日記
2019年12月08日
pbulk for NetBSD 9.0_RC1
Tool dependency checkperms>=1.1: NOT found
2019年11月30日
NetBSD-9.0_RC1-amd64-install.img.gz
2019年11月25日
一回目の大根を漬けた
2019年11月08日
math/py-tables
2019年11月03日
(Wanderlust) problem reading mail メールが読めなくなって
以上、1 日分です。
タイトル一覧
カテゴリ分類
Powered by hns-2.19.9, HyperNikkiSystem Project

Count.cgi (since 2000/02/05)