hns - 日記自動生成システム - Version 2.19.9

先月 2021年10月 来月
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31
Namazu for hns による簡易全文検索
詳しくは 詳細指定/ヘルプを参照して下さい
検索式:

2021年10月30日() 旧暦 [n年日記] [更新:"2021/10/30 13:01:34"]

#1 [pgp] encrypting by pgp key

  • I needed to encrypt by pgp keys
  • I've used gpg2 instead of gpg (on NetBSD)
  • I've got error as Unusable public key
    gpg: error retrieving 'makoto@example.com' via Local: Unusable public key
    gpg: error retrieving 'makoto@example.com' via WKD: No data
    gpg: makoto@example.com: skipped: No data
    gpg: /PATH/TO/vote-cleartext: encryption failed: No data
    
  • I've used following command to fix above problem
     gpg2 --expert --edit-key  (key-id)
      ...
     addkey 
    
reference (in Japanese)


2021年10月29日(金) 旧暦 [n年日記] [更新:"2004/08/09 23:43:33"]

#1 [NetBSD] kernel patch for Let's Note CF-SX[234]

The model I've tested is Panasonic, CF-SX3, related lines from dmesg:
[     1.041396] i915drmkms0 at pci0 dev 2 function 0: Intel HD Graphics (GT2) (rev. 0x0b)
[     3.103214] i915drmkms0: interrupting at msi6 vec 0 (i915drmkms0)
[     3.152610] intelfb0 at i915drmkms0
This note PC has been needed some patch to use built-in LCD. I've been using a patch from sloss (toughbook version)

Then, I have three type of kernels tested:

  1. No change (-current)
    9.0 - 9.99.x
    -> Internal LCD was OK for a while after boot, but black out after drmkms activated
    -> external HDMI/VGA works. If external HDMI connected, internal also LCD works
      (and small font appears at console of both display, meaning not intelfb mode)
    
  2. 2. local (adhoc and almost debug print) patch (9.99.91 at the moment)
    -> Internal LCD and external HDMI both works
    
    xrandr output is:
    ----------
    SX3@makoto 22:16:17/211030(~)% xrandr
    Screen 0: minimum 8 x 8, current 2680 x 1920, maximum 32767 x 32767
    eDP1 connected primary 1600x900+1080+0 (normal left inverted right x axis y axis) 260mm x 150mm
       1600x900      59.98*+  59.82  
       1400x900      59.88  
       1368x768      60.00    59.88    59.85  
       1280x800      59.81    59.91  
       1280x720      59.86    60.00    59.74  
       1024x768      60.00  
       1024x576      60.00    59.90    59.82  
       960x540       60.00    59.63    59.82  
       800x600       60.32    56.25  
       864x486       60.00    59.92    59.57  
       800x450       60.00  
       640x480       59.94  
       720x405       59.51    60.00    58.99  
       640x360       59.84    59.32    60.00  
    DP1 disconnected (normal left inverted right x axis y axis)
    HDMI1 connected 1080x1920+0+0 left (normal left inverted right x axis y axis) 510mm x 290mm
       1920x1080     60.00*+  50.00    59.94  
       1920x1080i    60.00    50.00    59.94  
       1680x1050     59.88  
       1280x1024     60.02  
       1280x960      60.00  
       1152x864      59.97  
       1280x720      60.00    50.00    59.94  
       1024x768      60.00  
       800x600       60.32  
       720x576       50.00  
       720x480       60.00    59.94  
       640x480       60.00    59.94  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    
    ----------
    
    3. rereredrm56 (9.99.88 at the mement)
    -> external VGA works fine but,
    -> external HDMI won't come out. xrandr shows following lines:
    ----------
    SX3@makoto 21:09:39/211030(~)% xrandr
    Screen 0: minimum 8 x 8, current 1600 x 900, maximum 32767 x 32767
    eDP1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 260mm x 150mm
       1600x900      59.98*+  59.82  
       1400x900      59.88  
       1368x768      60.00    59.88    59.85  
       1280x800      59.81    59.91  
       1280x720      59.86    60.00    59.74  
       1024x768      60.00  
       1024x576      60.00    59.90    59.82  
       960x540       60.00    59.63    59.82  
       800x600       60.32    56.25  
       864x486       60.00    59.92    59.57  
       800x450       60.00  
       640x480       59.94  
       720x405       59.51    60.00    58.99  
       640x360       59.84    59.32    60.00  
    DP1 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    -----
    


2021年10月27日(水) 旧暦 [n年日記] [更新:"2004/08/09 23:43:33"]

#1 [Perl] pass array pointer to subroutine

code:

#!/usr/pkg/bin/perl
use strict;
use feature qw(declared_refs refaliasing say);

sub print_array {
    my ($args)   = @_;
    my (\@ptr)   = $args -> {-ptr}; 
    my ($string) = $args -> {-string}; 

    print $string,"\n";

    foreach my $i (0..$#ptr){
        print $ptr[$i],"\n";
    }
}
sub main {
    my (@array) =  (qw ( 1 2 3 4 5 ));
    print_array ({
    		-ptr    => \@array,
		-string => ' -- passing array test -- '
    });
}
main();
__END__

results:

SX3@makoto 21:04:49/211027(..git-work/pass-array)% perl pass-array
Declaring references is experimental at pass-array line 8.
Aliasing via reference is experimental at pass-array line 8.
 -- passing array test -- 
1
2
3
4
5
SX3@makoto 21:05:02/211027(..git-work/pass-array)% perl --version

This is perl 5, version 34, subversion 0 (v5.34.0) built for x86_64-netbsd-thread-multi

Copyright 1987-2021, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.


2021年10月25日(月) 旧暦 [n年日記] [更新:"2004/08/09 23:43:33"]

#1 [pkgsrc] life of binary packages

I wrote short article on 'life of binary packages' (sorry in Japanese) But that is not enough. My real life of binary packges is:
  1. prepare CHROOTED pbulk environment
  2. watch the stable date of pkgsrc (and checkout that date)
    cvs update -D yyyy-mm-dd
    
    recent example is 2021-09-27
  3. create personal meta-package The package name beginning with config- is important in this context
  4. run pbulk with /limited_list = config-set (etc)
    recent example is:
    local-mef/config-set
    local-mef/config-R2021
    local-mef/config-office
    local-mef/emacs-desktop
    local-mef/config-cad
    local-mef/config-latex
    pkgtools/pkgin
    wm/fvwm3
    
  5. store the results somewhere

install or update to new release:

  • copy (presumably by wget) binary to local filesystem You need explicit version name, wget won't allow wildcard. check by following. (Supposing to have (old) pkgin is installed))
    pkgin search pkgin 
    
    1. pkgin
    2. pkg_install
    3. sudo
  • pkg_delete -ff '*'
  • su
  • pkg_add sudo (and exit from su)
  • sudo pkg_add pkgin
  • set repositories.conf to one of binary repository listed above
  • sudo pkgin install config-set

todays error (problem):

some package should not be and are not included
  • xv
  • eagle
Those should not be in personal binary packgage.


2021年10月17日() 旧暦 [n年日記] [更新:"2022/05/16 15:56:02"]

#1 [pkgsrc] mame-0.236 took 13.5 hours to package

$ ls -lt
total 58552
-rw-r--r--  1 root   wheel        77 Oct 17 03:16 package.log
-rw-r--r--  1 root   wheel      2643 Oct 17 03:16 install.log
-rw-r--r--  1 pbulk  wheel  29182753 Oct 17 03:16 work.log
-rw-r--r--  1 root   wheel    681350 Oct 17 03:15 build.log
-rw-r--r--  1 root   wheel      7021 Oct 16 13:42 configure.log
-rw-r--r--  1 root   wheel       152 Oct 16 13:41 checksum.log
-rw-r--r--  1 root   wheel      2179 Oct 16 13:40 depends.log
-rw-r--r--  1 root   wheel        29 Oct 16 13:40 pre-clean.log


2021年10月15日(金) 旧暦 [n年日記] [更新:"2021/10/15 01:23:59"]

#1 [NetBSD] images of bios-install and (just) install

NetBSD-9.99.91-amd64-bios-install.img.gz14-Oct-2021 12:491251490kB
NetBSD-9.99.91-amd64-install.img.gz14-Oct-2021 12:451251715kB
Is there any description on what is the difference above two ?

I've used the latter one to install to Let's Note CF-SX2 by writing to USB-disk,

zcat NetBSD-9.99.91-amd64-install.img.gz | sudo dd of=/dev/rsd0d bs=2m 
And its startup screen, it says 'bios boot'

By the way, the Note PC (built-in) LCD is black out. You need external LCD to start width. I usually make another modified kernel to use internal LCD.




最近の日記
2024年03月10日
停電 (瞬電)
2024年03月03日
the second try on bare-metal
useradd
2024年02月29日
opendkim and senmail
2024年01月24日
chat/iam 0.0.8
2024年01月21日
uselocale vs setlocale (textproc/R-readxl)
以上、6 日分です。
タイトル一覧
カテゴリ分類
Powered by hns-2.19.9, HyperNikkiSystem Project

Count.cgi (since 2000/02/05)