NetBSD2 | NetBSD | 1.6 | amd | autoconf | apache | bind | booting | boot/install/disk | boot-cd | build.sh | (daily) | Canna | CF+sendmail | cvs | dhcpd | dvi2ps | emacs-20 | ftpmirror | fvwm2 | gcc | gettext | ghostscript | inn | IPv6 | jitterbug | Install(OHP) | kernel | (old) | majordomo | make build | MHonArc | MRTG | namazu | ndtpd | PHP + PostgreSQL | netatalk | netboot | NFS | NIS | ntp | opie | Open Firmware | perl | procmail | sendmail | sharutils | smtpfeed | tcsh | TeX | time make | ucspi-tcp | w3 | wget | Wnn | wu-ftpd | X11 | Site Map |
全文検索

緊急・設置用 disk

disk を一つ用意する。例えば 40M くらいでもいい。 これに netbsd.GENERIC_MD.gz と ofwboot を入れておけば、 いつでも起動して作業が出来る。 もっとも CDROM や Network 起動が出来るのなら、この有難さは 特にない。

以前は、boot.fs が 一つだったので、dd で

dd if=boot.fs of=/dev/rsd0c bs=64k
のように、書いておけば、いつでも起動出来たのだけれど、 それが二枚になって、出来なくなってしまったので、 それの代替手段である。

作業

disk の大きさにもよるが、
  1. / 区画を作る
  2. その中に ofwboot と netbsd.GENERIC_MD.gz を入れ、後者は netbsd または netbsd.gz という名前にしておく
    (そうしない時には no active packageopen netbsd.GENERIC_MD.gz: Device not configured と出る )
  3. installboot で起動可にする。
のようにする。
 vi /etc/disktab
 disklabel -w -r /dev/rsd1c 40M mydisk
 disklabel sd1
 newfs /dev/rsd1a
 mount /dev/sd1a /mnt
 cd /mnt
 cp /net/quick/export/current-ts/20020819r/binary/kernel/netbsd.GENERIC_MD.gz 20020819r.gz
 cp /net/quick/export/current-ts/20020819d/usr/mdec/ofwboot .
 ln 20020819r.gz netbsd.gz
 cd /usr/mdec
 umount /mnt
 installboot -v -t ffs /dev/rsd1a bootxx /ofwboot
/etc/disktab
40M:\
        :ty=40M:se#512:nt#2:rm#300:ns#44:nc#928:\
        :pa#81664:oa#0:ba#4096:fa#512:ta=4.2BSD:\
        :pc#81664:oc#0:bc#4096:fc#512:tc=unused:
170M:\  
        :ty=170M:se#512:nt#2:rm#300:ns#71:nc#2337:\
        :pa#331854:oa#0:ba#4096:fa#512:ta=4.2BSD:\
        :pc#331854:oc#0:bc#4096:fc#512:tc=unused:     

installboot や /usr/mdec については 1.6 から変っているので、環境が違う時は、 このままでは出来ないかも知れないが考え方は同じ。

intallboot

# cd /usr/mdec
# umount /mnt
sd1: cache synchronization failed
#  installboot -v -t ffs /dev/rsd1a bootxx /ofwboot
File system:         /dev/rsd1a
File system type:    ffs (blocksize 4096, needswap 0)
Primary bootstrap:   bootxx
Secondary bootstrap: /ofwboot
installboot: `bootxx' cannot be larger than 2048 bytes
installboot: Set bootstrap operation failed
# ls -l /usr/mdec/
total 274
-r--r--r--  1 root  wheel   2271 Aug 16 23:15 bootxx
-r-xr-xr-x  1 root  wheel  88560 Aug 16 23:15 installboot
-r--r--r--  1 root  wheel    512 Aug 16 23:12 mbr
-r--r--r--  1 root  wheel  57568 Aug 16 23:15 ofwboot
-r--r--r--  1 root  wheel  61532 Aug 16 23:15 ofwboot.elf
-r--r--r--  1 root  wheel  57804 Aug 16 23:15 ofwboot.xcf
-r--r--r--  1 root  wheel   8192 Aug 16 23:15 ustarboot
# which installboot
/usr/sbin/installboot
# pwd
/usr/mdec
# ls -l
total 274
-r--r--r--  1 root  wheel   2271 Aug 16 23:15 bootxx
-r-xr-xr-x  1 root  wheel  88560 Aug 16 23:15 installboot
-r--r--r--  1 root  wheel    512 Aug 16 23:12 mbr
-r--r--r--  1 root  wheel  57568 Aug 16 23:15 ofwboot
-r--r--r--  1 root  wheel  61532 Aug 16 23:15 ofwboot.elf
-r--r--r--  1 root  wheel  57804 Aug 16 23:15 ofwboot.xcf
-r--r--r--  1 root  wheel   8192 Aug 16 23:15 ustarboot
# ./installboot -h
installboot: unknown option -- h
usage: installboot [-n] [-v]   
# ./installboot -v ofwboot bootxx /dev/rsd1a
boot: ofwboot
proto: bootxx
device: /dev/rsd1a
proto bootblock size: 1024
entry point: 0x00600000
ofwboot: block numbers: 
sd1: cache synchronization failed
# Aug 20 21:28:29 harry last message repeated 2 times

起動

0 > boot scsi/sd@6:0 
OF_open bootpath=scsi/sd@6
read stage 2 blocks: 012345678901234. done!
starting stage 2...

>> NetBSD/macppc OpenFirmware Boot, Revision 1.5
>> (root@quick, Mon Aug 19 22:52:41 JST 2002)
open /netbsd: Device not configured
5965492+219200=0x5e6108
 start=0x800000
[ netbsd ELF symbol table not valid ]
[ no symbol table formats found ]
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 1.6F (GENERIC_MD) #5: Tue Aug 20 08:12:22 JST 2002
    root@quick:/export/current-ts/20020817/obj/sys/arch/macppc/compile/GENERIC_MD
total memory = 112 MB
avail memory = 97856 KB
using 1459 buffers containing 5836 KB of memory
....
md0: internal 2048 KB image area
boot device: sd1
root on md0a dumps on md0b
root file system type: ffs
erase ^H, werase ^W, kill ^U, intr ^C, status ^T
Terminal type? [vt100] xterm
Erase is backspace.
(I)nstall, (S)hell or (H)alt ? 
Last Update
19:52:53 03/12/08
Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; ClaudeBot/1.0; +claudebot@anthropic.com)
Apache/2.0.65 (Unix) mod_ssl/2.0.65 OpenSSL/1.0.1g DAV/2 PHP/5.4.26
Count.cgi
(since 2002/08/20)