|
|
便利なツール Emacs らくらく 入門 ![]() |
|
Namazu for hns による簡易全文検索 詳しくは 詳細指定/ヘルプを参照して下さい |
||||||||||||||||||||||||||||||||||||||||||||||
2023年07月14日(金) 旧暦 [n年日記] [更新:"2004/08/09 23:43:33"]#1 [pkgsrc] firefox-115R firefox-115 on NetBSD/amd64 10.99.4 thread '<unnamed>' panicked at 'failed to allocate a guard page: File too large (os error 27)', library/std/src/sys/unix/thread.rs:829:17 stack backtrace: 9: 0x17c3e02 - rust_begin_unwind 10: 0xd38dc3 - core::panicking::panic_fmt::hd93d854e467e84d7 11: 0x17ca0cf - std::sys::unix::thread::guard::init::haff7244864348fc6 12: 0x17dd92c - std::rt::init::h73634ebfb6f192d6 13: 0x17ddafb - std::rt::lang_start_internal::h70dccf2ba1440102 14: 0xdc2165 - main 15: 0xcc537d - ___start fatal runtime error: initialization or cleanup bug ( つっこみ )
2010年07月14日(水) 旧暦 [n年日記] [更新:"2010/07/15 10:08:13"]#1 [機械] ML115 G1 の POST + BIOS を直列口に転送
実は長いこと知らなかった(注意しなかった)のだけれど ML115 の
少なくとも G1 は POST + BIOS の画面を直列口に転送出来る (神戸さんに教えてもらった)。
というのもあった。
さて POST で F10 を選んで起動した BIOS の画面の Advanced の項目に Advanced .. IPMI Console Redirection ...とあり、この Console Redirection を Enable にすれば良い。 更に (上の選択の中の一つ上の) IPMI の方で Serial Port Configuration Serial Port Assignment [System or BMC]の Serial Port を BMC の方に切替えて見た。(BMC: Base Management Controller) user/password ad**n/ad**n で CLI に入れて、show というのが殆 ど ls みたいなもので cd system1 してから reset すると強制再起動 が出来る でも実は (一度 BMC に渡してしまった、シリアルの方からは) BMC の設定を元に戻す方法が分っていない。 画面があれば起動時に F10 で BIOS 設定の画面になるので元には戻せる。 それで実は BIOS 設定 -> Advanced -> IPMI の中で Serial Port Configuration Serial Port Assignment [System] Serial Port Switching [Enabled]とすると ESC ( BMC ESC @ Systemとあり、これで System になっている方からは、いつでも ESC ( で BMC に切替えられる。しかし BMC になっている時にはどうも起動時の最初の短い間だけ ESC @ で System に戻せるという感触を持っている。 この最初の短い時間というのは、(もし画面が見られるなら) invent ProLiant の表示が出る前、ということだと思う。 しかも、ESC @ を何回も(遅くまで)入力していると、 これは F12 になるので Network boot を選んだ、と思われてしまう。 (もう三回もやってしまった) どうも 直列側に S が出たら、 もうそれで良いという時期のようだ。注意: BMC に行ってしまった場合、卓を取戻すには、 reset などで 強制再起動する しかない (というのが僕の今の理解)。 shutdown -r now で再起動させて、その時に取戻すのも可だけれど、 再起動が必要なことに変りはない。
2010/07/15 追記: ML115 G5, ML110 G2, の二機種でも同様のことを確認。
( つっこみ )
2008年07月14日(月) 旧暦 [n年日記] [更新:"2008/07/14 10:33:45"]#1 [NetBSD] mingw32-gcc
きのう
の続きで、では package を使わないで make 出来るのかを試して見た。
おそらく、次の方法で可能
(必要な三点は /usr/pkg 側に用意してあるという前提)。
env PATH=/usr/pkg/cross/bin:${PATH} \ ../gcc-4.2.1/configure \ --target=i386--mingw32 \ --host=i386--netbsd \ --build=i386--netbsd \ --enable-languages=c,c++ \ --disable-multilib \ --enable-sjlj-exceptions \ --disable-nls \ --prefix=/usr/pkg/cross/ env PATH=/usr/pkg/cross/bin:${PATH} gmakeには、随分簡単に書いてある。さて --host=, --build= 無でも試して見る .. だめそう。 mkdir build-i386-unknown-netbsdelf4.0.0. mkdir build-i386-unknown-netbsdelf4.0.0./libiberty Configuring in build-i386-unknown-netbsdelf4.0.0./libiberty configure: error: cannot find sources (xmalloc.c) in ../../gcc-4.2.1/libiberty gmake[1]: *** [configure-build-libiberty] Error 1 ( つっこみ )
2007年07月14日(土) 旧暦 [n年日記] [更新:"2007/07/20 20:38:57"]#1 [NetBSD] dereferencing pointer to incomplete typeIn file included from src/sys/lkm/vfs/hfs/lkminit_vfs.c:53: src/sys/fs/hfs/hfs.h: In function 'GET8B': src/sys/fs/hfs/hfs.h:133: error: dereferencing pointer to incomplete type src/sys/fs/hfs/hfs.h: In function 'GET16B': src/sys/fs/hfs/hfs.h:142: error: dereferencing pointer to incomplete type src/sys/fs/hfs/hfs.h: In function 'GET32B': src/sys/fs/hfs/hfs.h:151: error: dereferencing pointer to incomplete typeこんな簡単そうな問題が解けないなんてさびしいので、じっくりと: src/sys/fs/hfs/hfs.h: (これは名前が同じでも中身が全然違う)。以下の中身は、つばい版 38 #include <miscfs/genfs/genfs_node.h> 96 static u_int GET8B(struct buf *, int); 97 static u_int GET16B(struct buf *, int); 98 static u_int GET32B(struct buf *, int); 128 static inline u_int 129 GET8B(bp, off) 130 struct buf *bp; 131 int off; 132 { 133 u_int8_t *p = (char *)bp->b_data + off; 134 return *p; 135 } 136 137 static inline u_int 138 GET16B(bp, off) 139 struct buf *bp; 140 int off; 141 { 142 u_int16_t *p = (void *)((char *)bp->b_data + off); 143 return *p; 144 } 145 146 static inline u_int 147 GET32B(bp, off) 148 struct buf *bp; 149 int off; 150 { 151 u_int32_t *p = (void *)((char *)bp->b_data + off); 152 return *p; 153 }sys/sys/buf.h: 119 struct buf { 120 union { 121 TAILQ_ENTRY(buf) u_actq; /* Device driver queue when active. */ 122 #if defined(_KERNEL) /* u_work is smaller than u_actq. XXX */ 123 struct work u_work; 124 #endif /* defined(_KERNEL) */ 125 } b_u; 126 #define b_actq b_u.u_actq 127 #define b_work b_u.u_work 128 struct simplelock b_interlock; /* Lock for b_flags changes */ 129 volatile int b_flags; /* B_* flags. */ 130 int b_error; /* Errno value. */ 131 int b_prio; /* Hint for buffer queue discipline. */ 132 int b_bufsize; /* Allocated buffer size. */ 133 int b_bcount; /* Valid bytes in buffer. */ 134 int b_resid; /* Remaining I/O. */ 135 dev_t b_dev; /* Device associated with buffer. */ 136 struct { 137 void * b_addr; /* Memory, superblocks, indirect etc. */ 138 } b_un; .. 188 #define b_data b_un.b_addr /* b_un.b_addr is not changeable. */dereferencing pointer to incomplete type の 日本語訳は 「ポインタ元へ参照の時に型が合っていない」 +--------+ ポインタ →| 実体 | +--------+ポインタ参照 (pointer reference) とは、実体をポインタの値(アドレス)を使って参照したり 取扱ったりすること ポインタ元へ参照とは、実体の値を得ること (だと思う) b_addr は void * しかし最近は caddr_t になっている。逆か、以前は caddr_t で最近は void *。 上の問題は、実は 単に #include <sys/buf.h> が抜けていただけ のようだ。 こういう、何か不可解な場合、「単に定義されていないだけ」というのが良くある。 @ ./build.sh sets:
という訳で、最後は ./build.sh sets だったけれど、久し振りに release が出来た。
===> Successful make sets ===> build.sh ended: Sun Jul 15 02:08:24 JST 2007 ===> Summary of results: build.sh command: ./build.sh -u -T /export/20070526ts/checkout/src/tooldir.NetBSD-4.99.9-powerpc sets build.sh started: Sun Jul 15 02:06:16 JST 2007 NetBSD version: 4.99.20 MACHINE: macppc MACHINE_ARCH: powerpc Build platform: NetBSD 4.99.9 macppc HOST_SH: /bin/sh TOOLDIR path: /export/20070526ts/checkout/src/tooldir.NetBSD-4.99.9-powerpc DESTDIR path: /export/20070526ts/checkout/src/obj/destdir.macppc RELEASEDIR path: /export/20070526ts/checkout/src/obj/releasedir makewrapper: /export/20070526ts/checkout/src/tooldir.NetBSD-4.99.9-powerpc/bin/nbmake-macppc Updated /export/20070526ts/checkout/src/tooldir.NetBSD-4.99.9-powerpc/bin/nbmake-macppc Building sets from pre-populated /export/20070526ts/checkout/src/obj/destdir.macppc Successful make sets build.sh ended: Sun Jul 15 02:08:24 JST 2007 ===> .(と思ったら kernel が出来ていない、どうも変だと思った) -u を不用意に使うと、こうなるらしい。 ... ではなくて、flist で失敗した。flist を通すようにした。通ったので全て 終ったと思って sets を実行、というのが違っていて、「flist check が終っても」 まだ終了には程遠い、ということだったと思う。 ( つっこみ )
2006年07月14日(金) 旧暦 [n年日記] [更新:"2006/07/14 21:24:23"]#1 [FreeBSD] ndis driver ってどうなっているのかなとcd /tmp rsync -a rsync://rsync.allbsd.org/freebsd-cvs/src/sys/dev/if_ndis/ if_ndis/これで手元に持って来れた。allbsd.org and hrs 有難し (実はこれは cvs repository だった)。 ( つっこみ )
2005年07月14日(木) 旧暦 [n年日記] [更新:"2005/07/14 15:25:31"]#1 [DNS] No addresses for MX
dig mx hoge.example.com とやると、
hoge.example.com. 28104 IN MX 10 59.106.14.19.のように、IP address が返って来るのって ? 正しい設定方法なのかな。 手元の sendmail 220 myhost.example.com ESMTP Sendmail 8.13.1/8.13.1; Thu, 14 Jul 2005 10:18:11 +0900 (JST)は、 DSN: Service unavailable (<hoge.example.com>... No addresses for MX (59.106.14.19))と言って、メールを送ってくれない。あまり感心しないとしても、 送って呉れてもいいようなものだ。 cf/README の設定にあるのかな。 それとも最後の . が問題 ? @ hirobo さんより:( つっこみ )
2003年07月14日(月) 旧暦 [n年日記]#2 [gcc] 忘れていた話
triage = 選別
実は bugzilla を見るのは初めてだったりして ( つっこみ )
#1 [C] getopt.c 比較@ src/gnu:(...src/gnu)> find . -name getopt.c -ls 21977 Jan 8 2001 ./dist/bc/lib/getopt.c 21874 Sep 5 2000 ./dist/cvs/lib/getopt.c 30595 Jan 26 09:43 ./dist/diffutils/lib/getopt.c 28770 Jun 27 1999 ./dist/gawk/getopt.c 30123 Oct 31 2000 ./dist/gettext/lib/getopt.c 30019 Jan 27 08:15 ./dist/grep/lib/getopt.c 34565 Jul 1 02:52 ./dist/groff/src/libs/libgroff/getopt.c 34416 Feb 13 17:57 ./dist/texinfo/lib/getopt.c 30126 Apr 23 2001 ./dist/toolchain/libiberty/getopt.c 29975 Jul 26 2000 ./dist/toolchain/texinfo/lib/getopt.c 22198 Jul 26 2000 ./dist/toolchain/texinfo/libtxi/getopt.c 18047 Feb 4 1998 ./libexec/uucp/libuucp/getopt.c 21541 Jan 16 2001 ./usr.bin/gzip/getopt.c @ diff |wc:(...src/gnu)> foreach i ( `find . -name getopt.c` ) echo $i diff foreach? echo $i foreach? diff ~/software/NAMAZU/develop/head/namazu/lib/getopt.c $i | wc foreach? end ./dist/bc/lib/getopt.c 549 2478 15428 ./dist/cvs/lib/getopt.c 551 2426 15219 ./dist/diffutils/lib/getopt.c 74 473 2767 ./dist/gawk/getopt.c 384 1673 10850 ./dist/gettext/lib/getopt.c 199 901 5585 ./dist/grep/lib/getopt.c 187 860 5162 ./dist/groff/src/libs/libgroff/getopt.c 331 1215 8034 ./dist/texinfo/lib/getopt.c 374 1499 9654 ./dist/toolchain/libiberty/getopt.c 196 843 5136 ./dist/toolchain/texinfo/lib/getopt.c 302 1285 8024 ./dist/toolchain/texinfo/libtxi/getopt.c 558 2499 15675 ./libexec/uucp/libuucp/getopt.c 837 4039 24530 ./usr.bin/gzip/getopt.c 898 4250 25862 ttyp0:makoto@toyoko 10:04:39/030714(...src/gnu)> @ 過去のメール:を見ていて、 kakasi-2.3.4 の getopt.c getopt1.c getopt.h を持って来たら、 何の問題もなく =================== All 46 tests passed ===================した。 ( つっこみ )
2001年07月14日(土) 旧暦 [n年日記]#2 [ChiBUG] 11:00-17:00
( つっこみ )
#1 [inn] inn server の引越
iBook を持出す必要があるので、別の機械と ipaddres ごと取替える
-r-xr-sr-x 1 news news 176723 Jul 10 16:16 bin/inews -r-sr-x--- 1 root news 101037 Jul 10 16:15 bin/inndstart -r-sr-x--- 1 root news 89564 Jul 10 16:16 bin/startinnfeed僕は 100:8 を使っていた。 それを知らずに tar で写してしまったので 6:8 になって、問題がある。 eval: /usr/local/news/bin/inndstart: permission denied chown -R news.news /usr/local/news すると setuid してあるものがなくなってしまうので 手で上のように直す ( つっこみ )
2000年07月14日(金) 旧暦 [n年日記]
4600+5700=10300歩
#2 [Apache] SSI
どうしても不思議なことがあって、
index.shtml <!--#include file=".index.html"-->としている場合に、通常なら、含まれている方の中には SSI の指示は書けないというか、無視されるはずなのに、 [- 日記システム警告:コマンド SSI は予約されています。-] ある一つの場合だけ、動いてしまう。 <!--#fsize file="filename" -->のような場合で、しかも、同じものを別の機械に持って いくと読まない。 ( つっこみ )
#1 [歩] やはりどこかで零に戻ってしまうようだ。
五反田近辺と荻窪界隈 ( つっこみ )
|
最近の日記 2025年02月13日 ・dvipdfmx ICC profile format spec. version 4.3.0 2025年01月29日 ・ham/wsjtx 2025年01月27日 ・wip/wsjtx 5.4.2 2025年01月25日 ・ham/wsjtx 2025年01月15日 ・今更 advent calendar | ||