hns - 日記自動生成システム - Version 2.19.9

先月 2005年02月 来月
1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28
Namazu for hns による簡易全文検索
詳しくは 詳細指定/ヘルプを参照して下さい
検索式:

2005年02月20日() 旧暦 [n年日記] [更新:"2005/02/20 22:54:38"]

#1 [NetBSD][pkgsrc][emulators] COMPAT_LINUX

カーネルの config に
options COMPAT_LINUX 
が定義されていない機械で、linux の実行形式 (binary)を実行 しようとすると、NetBSD emulation になってしまい、 syscall の番号が正しくないものを実行してしまったりする。 options COMPAT_LINUX が定義されているカーネルでは、次のような 変数を見ることが出来る。
sysctl -a | grep -i linux
emul.linux.kern.ostype = Linux
emul.linux.kern.osrelease = 2.4.18
emul.linux.kern.osversion = #0 Wed Feb 20 20:00:02 CET 2002
そこで、そのようなものが定義されていない場合には、実行しない ように気を付けた方がいい。人間の監視に期待するのは変だが。

で、例えば、pkgsrc/emulators/suse_base を COMPAT_LINUX の定義されていないカーネルで make install した時に、時計が 1970/1/1 になってしまうのを 避けるには、次のような修正をしておくといい。 LINUX_SYSCTL_OSRELEASE はたまたま、 suse_linux/Makefile.application で調べているので、それを利用することにしている。

Index: Makefile
===================================================================
RCS file: /e/st4200/cvsync/pkgsrc/emulators/suse_base/Makefile,v
retrieving revision 1.52
diff -u -r1.52 Makefile
--- Makefile	23 Jan 2005 12:06:07 -0000	1.52
+++ Makefile	1 Jan 1970 20:05:48 -0000
@@ -25,6 +25,10 @@
 RPMFILES=		aaa_dir.rpm gppshare.rpm ncurses.rpm \
 			readline.rpm bash.rpm sh-utils.rpm
 
+.if !defined(LINUX_SYSCTL_OSRELEASE)
+PKG_SKIP_REASON+= "${PKGNAME} is not available for ${MACHINE_PLATFORM}, needs 'options COMPAT_LINUX' in kernel config"
+.endif
+
 .include "../../emulators/suse_linux/arch.mk"
 
 .if ${SUSE_ARCH} == "i386"
これで安心して
cd pkgsrc/mk
time sudo sh bulk/build
出来る気がする。

#2 options COMPAT_LINUX

When this line is defined in kernel config, I've got the error
cc -O2 -pipe -Werror -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-main -Wno-format-zero-length -Wno-nonnull -Wno-uninitialized -msoft-float -fno-zero-initialized-in-bss -ffreestanding -I. -I../../../../arch -I../../../.. -nostdinc -DDIAGNOSTIC -DCPUVERBOSE -DZS_CONSOLE_ABORT -DMAXUSERS=32 -D_KERNEL -D_KERNEL_OPT -Dmacppc -I../../../../dist/ipf -c ../../../../compat/linux/common/linux_sg.c
In file included from ../../../../compat/linux/common/linux_sg.c:41:
../../../../dev/scsipi/scsiconf.h:65: error: field `sc_dev' has incomplete type
*** Error code 1

Stop.
make: stopped in /export/src-20050214ts/sys/arch/macppc/compile/INSECURE-ZS-L2-1M-PB2-SHM
508.118u 51.903s 9:14.20 101.0% 0+0k 98+2504io 1532pf+0w
So I applied the patch
--- ../usr/src/sys/compat/linux/common/linux_sg.c	2005-02-15 22:11:58.000000000 +0900
+++ sys/compat/linux/common/linux_sg.c	1970-01-02 04:32:40.000000000 +0900
@@ -38,7 +38,7 @@
 
 #include <sys/scsiio.h>
 #include <dev/scsipi/scsipi_all.h>
-#inpclude <dev/scsipi/scsiconf.h>
+#include <dev/scsipi/scsipiconf.h>
 
 #include <sys/sa.h>
 #include <sys/syscallargs.h>


#3 [NetBSD][pkgsrc] audio/darkice

Is this the right thing ?

ttypa:makoto@st4200  16:00:41/050220(...audio/darkice)> darkice -v 10 -c /usr/pkg/etc/darkice.conf
DarkIce 0.14 live audio streamer, http://darkice.sourceforge.net
Copyright (c) 2000-2004, Tyrell Hungary, http://tyrell.hu

Using config file: /usr/pkg/etc/darkice.conf
Using OSS DSP input device: /dev/audio1
16:00:50: encoding
16:00:50: Not running as super-user, unable to use POSIX real-time scheduling
16:00:50: It is recommended that you run this program as super-user
DarkIce: DarkIce.cpp:963: can't open connector [0]
/dev/audio1 was temporarily unavailable. Plug off USB and then plug in restores the situation. Then I got:
ttypa:makoto@st4200  16:09:29/050220(...audio/darkice)> sudo darkice -v 10 -c /usr/pkg/etc/darkice.conf
DarkIce 0.14 live audio streamer, http://darkice.sourceforge.net
Copyright (c) 2000-2004, Tyrell Hungary, http://tyrell.hu

Using config file: /usr/pkg/etc/darkice.conf
Using OSS DSP input device: /dev/audio1
16:11:50: encoding
16:11:50: scheduler high priority 78
16:11:50: Using POSIX real-time scheduling, priority 77
16:11:50: BufferedSink, new peak: 0
16:11:50: BufferedSink, remaining: 61440
16:11:50: BufferedSink, new peak: 7
16:11:50: BufferedSink, remaining: 61433
16:11:50: BufferedSink, new peak: 8
16:11:50: BufferedSink, remaining: 61432
16:11:50: BufferedSink, new peak: 22
16:11:50: BufferedSink, remaining: 61418
DarkIce: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]
ttypa:makoto@st4200  16:11:50/050220(...audio/darkice)> 
this message means that for some reason darkice couldn"t connect to icecast. this could either be that the server name or port parameter is not correct, or you have supplied a wrong password.

#4 [pkgsrc] cyrus-imapd gone ?

うめさんの日記 より
予告されていた通り、ports/mail/cyrus-imapd が削除された。 本家では既に 2.2.X が stable 扱いになり、2.0.X は 2.0.17 で開発が凍結されていた。2.0.17 は SASLv1 を使う最後のリリースであり、port はできるだけ残しておきたいと思っていたが、脆弱性が報告され、対策もされない状態なので、いよいよ消すことになった。 さようなら、ports/mail/cyrus-imapd。
あれ、使ってはいけないのかな...

#5 [pkgsrc][bulk-build][MacOSX] /bin/sh: -c: line 1: syntax error near unexpected token `)'

I have reported on 2/10 I've got following error.
===> *** '/usr/pkg/sbin/download-vulnerability-list'.
===> Creating toolchain wrappers for perl-5.8.6nb2
/bin/sh: -c: line 1: syntax error near unexpected token `)'
*** Error code 2
This is because X11BASE was empty. libtool-base had the same error. By writing following line in /etc/mk.conf,
X11BASE= /usr/X11R6
this problem is fixed.



最近の日記
2024年07月03日
kicad oddity
2024年05月08日
comparison on ./buildsh tools
2024年05月06日
py-setuptools (python 3.11.9)
make release took 1 hours and 10 min
qemu invocation for 10.99.10
2024年05月05日
Windows 10 version
serial connection
bc bench
2024年05月04日
Trial on 10.99.10
another version (later trial) to succeed
以上、1 日分です。
タイトル一覧
カテゴリ分類
Powered by hns-2.19.9, HyperNikkiSystem Project

Count.cgi (since 2000/02/05)