|
|
便利なツール Emacs らくらく 入門 ![]() |
|
Namazu for hns による簡易全文検索 詳しくは 詳細指定/ヘルプを参照して下さい |
||||||||||||||||||||||||||||||||||||||||||||||
2023年09月11日(月) 旧暦 [n年日記] [更新:"2004/08/09 23:43:33"]#1 [NetBSD] chroot and pbulk@ download:
images directory under:
-rw-r--r-- 1 makoto wheel 884887151 Sep 10 15:07 NetBSD-10.99.8-amd64-bios-install.img.gz @ USB memory or usb Hard disk:zcat 884887151 Sep 10 15:07 NetBSD-10.99.8-amd64-bios-install.img.gz | \ sudo dd of= /dev/rsd0d bs=2m @ sysinst:@ copy binaries to /usr/INSTALL:
rsync -avH /mnt/amd64/ to /export/CHROOT-10.99.8/usr/INSTALL/
@ unpack under CHROOT:h97@makoto 00:09:47/230911(/export/CHROOT-10.99.8)% \ foreach i (`cd /export/CHROOT-10.99.8/usr/INSTALL/binary/sets; ls *.xz|grep -v kern` ) echo $i; sudo pax -r -z -pe -f /export/CHROOT-10.99.8/usr/INSTALL/binary/sets/$i; end base.tar.xz comp.tar.xz debug.tar.xz etc.tar.xz games.tar.xz gpufw.tar.xz man.tar.xz misc.tar.xz modules.tar.xz rescue.tar.xz tests.tar.xz text.tar.xz xbase.tar.xz xcomp.tar.xz xdebug.tar.xz xetc.tar.xz xfont.tar.xz xserver.tar.xz h97@makoto 00:11:23/230911(/export/CHROOT-10.99.8)% @ adjustment on CHROOT:
@ bootstrap:
set -E
cd /usr/pkgsrc/bootstrap ./bootstrap --prefix=/usr/pkg_bulk --pkgdbdir=/usr/pkg_bulk/.pkgdbdir ===> bootstrap started: Sun Sep 10 15:29:06 UTC 2023 ===> bootstrap ended: Sun Sep 10 15:31:00 UTC 2023 @ pbulk:
/usr/pkg_bulk/etc/mk.conf
PACKAGES= /packages_bulk SKIP_LICENSE_CHECK= yes cd /usr/pkgsrc/pkgtools/pbulk ; env PATH=/usr/pkg_bulk/bin:/usr/pkg_bulk/sbin:${PATH} bmake package-install @ addendum:# cd ../../local-mef/pbulk-* # pwd /usr/pkgsrc/local-mef/pbulk-addendum # env PATH=/usr/pkg_bulk/bin:/usr/pkg_bulk/sbin:${PATH} bmake package-installenv PATH=/usr/pkg_bulk/bin:/usr/pkg_bulk/sbin:${PATH} pkg_info -u @ setup pbulk.conf:--- usr/pkg_bulk/etc/pbulk.conf.orig 2023-09-11 07:09:32.872762710 +0900 +++ usr/pkg_bulk/etc/pbulk.conf 2023-09-11 07:53:02.871242484 +0900 @@ -17,7 +17,7 @@ # On a single-processor, non-distributed build, you may want to say "no" # here. # -master_mode=yes +master_mode=no master_ip=192.168.75.10 scan_clients="192.168.75.21 192.168.75.22 192.168.75.23 192.168.75.24" @@ -29,20 +29,20 @@ # Some flags for the programs that publish the binary packages and the # build report. If you want to disable the publishing at all, see below. # -pkg_rsync_args="-av --delete-excluded -e ssh" -pkg_rsync_target="pkgsrc@192.168.75.1:/public/packages/current/DragonFly-1.8" -report_rsync_args="-avz --delete-excluded -e ssh" -report_rsync_target="pkgsrc@192.168.75.1:/public/reports/current/DragonFly-1.8" -report_subject_prefix="pkgsrc" -report_recipients="pkgsrc-bulk@netbsd.org" +pkg_rsync_args="-av --delete-excluded" +pkg_rsync_target="/bulk/rsync" +report_rsync_args="-avz --delete-excluded" +report_rsync_target="/bulk/report" +report_subject_prefix="10.99.8" +report_recipients="makoto@if.t.u-tokyo.ac.jp" # An archive containing the pkgsrc binary tree after bootstrapping. # -bootstrapkit=/usr/pkgsrc/bootstrap/bootstrap.tar.gz +bootstrapkit= # Optionally build a subset of the available packages and their dependencies. # The file is a newline separated list of package locations (e.g. lang/perl5). -#limited_list=/limited_list +limited_list=/limited-list # Optionally ignore unresolvable dependencies for a full build (e.g. # a build without limited_list set). Default behavior is to bail out. @@ -96,7 +96,7 @@ gzip="/usr/bin/gzip -nf -9" # On non-NetBSD, this should usually point at the bmake in ${prefix}, not the # make used to build pbulk itself. -make=${prefix}/bin/bmake +make=/usr/bin/make mail=/usr/bin/mail neato=/usr/pkg_bulk/bin/neato rsync=/usr/pkg_bulk/bin/rsync @ /limited-list:( つっこみ )
2015年09月11日(金) 旧暦 [n年日記] [更新:"2015/09/11 15:18:28"]#2 [FreeBSD] make show-var VARNAME=hoge
Adding following
patch
to /usr/ports/Mk/bsd.port.mk may give convenient target --- Mk/bsd.port.mk.orig 2015-09-12 00:47:22.100599000 +0900 +++ Mk/bsd.port.mk 2015-09-12 00:41:04.369753000 +0900 @@ -2934,6 +3007,31 @@ describe: @${DO_NADA} .endif +# convenience target, to display make variables from command line +# i.e. "make show-var VARNAME=var", will print var's value +# +# See also: +# show-vars, show-subdir-var +# +.PHONY: show-var +show-var: + @${ECHO} ${${VARNAME}:Q} + +# enhanced version of target above, to display multiple variables +.PHONY: show-vars +show-vars: +.for VARNAME in ${VARNAMES} + @${ECHO} ${${VARNAME}:Q} +.endfor + +# displays multiple variables as shell expressions +# VARS is space separated list of VARNAME:shellvarname +.PHONY: show-vars-eval +show-vars-eval: +.for var in ${VARS} + @${ECHO} ${var:C/^.*://}="${${var:C/:.*$//}:Q}" +.endfor + ################################################################ # More standard targets start here. # ( つっこみ )
#1 [FreeBSD] cloning ports with svn
After reading the page
A ports/lang/gcc-aux/Makefile A ports/lang/ats/Makefile A ports/lang/ats/files/patch-Makefile__bootstrap svn: E120108: Error running context: The server unexpectedly closed the connection. h97@makoto 23:54:27/150911(/export/svn-work)% echo svn update ports svn update ports h97@makoto 23:54:51/150911(/export/svn-work)% history 6 less /export/WRKOBJDIR/ham/gnuradio-ctrlport/work/gnuradio-3.7.8/ 7 cd /export/CHROOT/usr/pkgsrc/wip/virtualbox-ose 8 (cd /export/WRKOBJDIR/wip/virtualbox-ose/work/VirtualBox-4.3.30; diff -up configure{~,}) 9 (cd /export/WRKOBJDIR/wip/virtualbox-ose/work/VirtualBox-4.3.30; diff -up configure{~,}) > patches/patch-configure 10 make clean 11 make distinfo 12 make 13 ls patches 14 ls -lt patches 15 ls /export 16 cd /export 17 mkdir svn-work 18 cd svn-work 19 svn checkout https://svn.FreeBSD.org/ports/head /usr/ports 20 svn checkout https://svn.FreeBSD.org/ports/head ports 21 echo svn update ports h97@makoto 23:54:56/150911(/export/svn-work)% ( つっこみ )
2010年09月11日(土) 旧暦 [n年日記] [更新:"2010/09/29 06:23:24"]#1 [無題] 新潟方面にアンテナ工事と見学
KT-20R
のようなものを無料で解体工事の上、部材引取、ということで
三人で出かける。
03:50 起床 04:05 出発 04:31 千葉駅 05:58 三鷹 07:50 赤城高原 SA 10:00 新潟江南区 16:45 JA0FVU の案内で JA0DAI アンテナ見学 18:10 小出 IC JA0 DX gang の方々と会合 23:00 栃尾又温泉泊った宿: 神風館 翌 12 日は雨の中 08:00 から JH0JHA のアンテナと JA0LHU のリモート制御シャックを見学。 いたや さんで、そばをごちそうになる。 ( つっこみ )
2006年09月11日(月) 旧暦 [n年日記] [更新:"2006/09/12 08:34:41"]#1 [NetBSD][pkgsrc] personal-pkgsrc
普段の生活に必要な config-serv と config-desktop がやっと出来た
気がする。
devel/doxygen と
benchmarks/bonnie を追加していなかったので、取敢えず手動で追加。
( つっこみ )
2003年09月11日(木) 旧暦 [n年日記]#2 [Linux] amdpts/0:root@localhost 22:54:40/030904(/etc)# /etc/rc.d/init.d/amd restart何かなぁ。 /* * Flush map cache */ if (flush_flag) { int *rc; amq_setopt opt; opt.as_opt = AMOPT_FLUSHMAPC; opt.as_str = ""; rc = amqproc_setopt_1(&opt, clnt); if (!rc || *rc) { fprintf(stderr, "%s: amd on %s cannot flush the map cache\n", __progname, server); errs = 1; } } ( つっこみ )
#1 [FreeWnn] cvs にある tar 形式 を ./configure
(NetBSD-current)
09/08
の続き
+ available_tags= CXX F77 ( つっこみ )
2002年09月11日(水) 旧暦 [n年日記]#1 [NetBSD] fontutils-0.7
意味が良く分っていないが、入れて見る。
( つっこみ )
2001年09月11日(火) 旧暦 [n年日記]#4 [Namazu] VPATH
竹迫さんが試して下さって make install する前だとうまく行かない
とのこと。
作り直したもの mknmz: 存在する索引は古い形式です。今は対応していません FAIL: ../../namazu/tests/mknmz-2なんて言われてしまう。これって出力先がない時だったかな。 時間切れ。きょうはおしまい。 ( つっこみ )
#3 [Namazu] 文書フィルタ
どこかで読んだ気がしたが、なかなか見つからなかった
(
search.namazu.org
でも見つからないし)。やっと見つかった。
これを読んだ後の僕の理解 (や付け足や疑問)
@ jeedosaquin.pl:
というのを一応作って見た。
次の一行目の表示も変えたい(170. を消したい) が、これはどこでやればいい ? 1. 170.make.html (点数: 2) 著者: 不明 日付: Tue, 11 Sep 2001 08:00:05 make に必要なもの 2.0 の版を作るために次のものが必要になります。 (お名前の敬称は略させていただきます。ごめんなさい) 名称 説明 必須 最新版 必要な版 譜名 作成・配布 入手先(例) その 他 Perl Perl 言語処 /amd/ki.nu./export/home/htdocs/software/namazu/tut/make.html (7,782 bytes)$fields->{'subjec'} らしい。 いまのコードは何でもかんでも *.html を x-type: jdsq にしてしまう。 add_magic のやり方は、また別の問題 ? ( つっこみ )
#2 [Namazu] nkf の最適化cc -O -o nkf nkf.cだけれど -O2 にすると、どうだろう。 まずは時間を測る方法を考えておかなくては。 namazu-dev でいいのかな。 #!/bin/sh MANUAL=/usr/local/share/namazu/doc/ja/manual.html TUTORIAL=/usr/local/share/namazu/doc/ja/tutorial.html export MANUAL export TUTORIAL for i in 1 2 3 4 5 6 7 8 9 10 do for j in 1 2 3 4 5 6 7 8 9 10 do nkf $MANUAL > /dev/null nkf $TUTORIAL > /dev/null done done測定結果一例。(誤差の範囲で変化なし) makoto@u ■12:21:10/010911(~/namazu)> time ./nkf-test 1.495u 3.450s 0:09.43 52.3% 0+0k 0+0io 0pf+0w makoto@u ■13:49:43/010911(~/namazu)> time ./nkf-test 0.516u 1.943s 0:06.66 36.7% 0+0k 0+0io 0pf+0w @ メール 100 日分:mknmz -f ~/.mknmzrc-Mail -O /home6/namazu/Mail-911 --mtime -100 Mail単に覚えということで 18751/18751 - /amd/ki.nu./export/home/makoto/Mail/uucp-host/127 [message/rfc822] 索引を書き出しています... [基本] 日付: Tue Sep 11 12:39:53 2001 追加された文書の数: 18,751 大きさ (bytes): 71,837,464 合計の文書数: 18,751 追加鍵語数: 554,728 合計鍵語数: 554,728 わかち書き: module_kakasi -ieuc -oeuc -w 経過時間 (秒): 15,755 譜/秒: 1.19 系: netbsd Perl: 5.006001 Namazu: 2.0.7pre1 ( つっこみ )
#1 [Namazu] 2.0.7pre2
(15 号台風模様の中)
VPATH 修正: http://www.namazu.org/ml/namazu-devel-ja/msg01957.html を使って作って見る。 (kakasi を入替えたら Text-Kakasi も入直しかな = 1.04) VPATH 修正の一部は既に入っているので 1 out of 1 hunks failed--saving rejects to nmz/Makefile.am.rej 1 out of 1 hunks failed--saving rejects to src/Makefile.am.rej @ 試しに --with-included-gettext 無でやって見る:checking whether NLS is requested... yes checking whether included gettext is requested... no checking for libintl.h... yes checking for gettext in libc... no checking for bindtextdomain in -lintl... yes checking for gettext in libintl... checking for gettext in -lintl... yes yes checking for msgfmt... /usr/local/bin/msgfmt checking for dcgettext... no checking for gmsgfmt... /usr/local/bin/msgfmt checking for xgettext... /usr/local/bin/xgettext checking for catalogs to be installed... ja ja_JP.SJIS es fr @ config.log から:configure:6374: checking for bindtextdomain in -lintl configure:6393: gcc -o conftest -g -O2 -Wall -pedantic conftest.c -lintl 1>&5 configure:6409: checking for gettext in libintl configure:6414: checking for gettext in -lintl configure:6433: gcc -o conftest -g -O2 -Wall -pedantic conftest.c -lintl 1>&5 configure:6472: checking for msgfmt @ checking for dcgettext... no の方は -lintl が要るのでは ?:
config.log から
configure:6506: checking for dcgettext configure:6534: gcc -o conftest -g -O2 -Wall -pedantic conftest.c 1>&5 /tmp/ccmTkbJ9.o: In function `main': /usr/local/src/pre2-vpath/configure:6528: undefined reference to `dcgettext' collect2: ld returned 1 exit status configure: failed program was: #line 6511 "configure" #include "confdefs.h" /* System header to define __stub macros and hopefully few prototypes, which can conflict with char dcgettext(); below. */ #include <assert.h> /* Override any gcc2 internal prototype to avoid an error. */ /* We use char because int might match the return type of a gcc2 builtin and then its argument prototype would still apply. */ char dcgettext(); int main() { /* The GNU C library defines this for functions which it implements to always fail with ENOSYS. Some functions are actually named something starting with __ and the normal name is an alias. */ #if defined (__stub_dcgettext) || defined (__stub___dcgettext) choke me #else dcgettext(); #endif ; return 0; } @ 6442 LIBS="$ac_save_LIBS":
configure の 6419 行目で
6415 if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then 6416 echo $ac_n "(cached) $ac_c" 1>&6 6417 else 6418 ac_save_LIBS="$LIBS" 6419 LIBS="-lintl $LIBS"で -lintl を付けているのに(条件が合わないのか) 6442 LIBS="$ac_save_LIBS" 6443 6444 fiと捨てしまっている /usr/local/share/aclocal/gettext.m4 の 0.10.35 と 0.10.38 を 比べると、この辺は変更があって、(手で移動しているけれど) + dnl If an already present or preinstalled GNU gettext() is found, + dnl use it. But if this macro is used in GNU gettext, and GNU + dnl gettext is already preinstalled in libintl, we update this + dnl libintl. (Cf. the install rule in intl/Makefile.in.) - if test "$gt_cv_func_gettext_libc" = "yes" \ - || test "$gt_cv_func_gettext_libintl" = "yes"; then + if test "$gt_cv_func_gnugettext_libc" = "yes" \ + || { test "$gt_cv_func_gnugettext_libintl" = "yes" \ + && test "$PACKAGE" != gettext; }; then - AC_DEFINE(HAVE_GETTEXT) - AM_PATH_PROG_WITH_TEST(MSGFMT, msgfmt, - [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], no)dnl - if test "$MSGFMT" != "no"; then - AC_CHECK_FUNCS(dcgettext) - AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT) - AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext, - [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :) .. + AC_DEFINE(HAVE_GETTEXT, 1, + [Define if the GNU gettext() function is already present or preinstalled.])これを調べる元気はちょっと出ないけれど、0.10.38 でなくて 0.10.35 を使っている理由 は何かな。 @ pre2 まとめ。:116 10:54 tar zxf /home6/tar_files/namazu-2.0.7pre2.tar.gz 118 10:56 cd namazu-2.0.7pre2/scripts/ 119 10:56 patch -s < /home/ftp/pub/namazu/2000-0327-fast-EXCLUDE-patch 120 10:56 cd .. 121 10:57 zcat /home/ftp/pub/namazu/2.0.7-more-japanese-20010907.gz | patch -s -p1 123 10:57 patch -s -p1 < ~/public_html/diary/attach/20010910-VPATH-3 126 10:58 cd .. 128 10:59 mkdir pre2-vpath 129 10:59 cd pre2-vpath 140 11:21 ../namazu-2.0.7pre2/configure --with-included-gettext 141 11:23 time make ; time make check All 40 tests passed ( つっこみ )
2000年09月11日(月) 旧暦 [n年日記]#2 [iBook] の位置指示系 (pointing device)
トラックパッドというのだと思うけれど、iBook には鼠の代りに四角い操作盤
が付いている。X Window system を動かして、鍵盤を操作していると、それに
手が触れてしまい、不要に矢印が動いてしまう。
砂川さんが、「右に寄り過ぎている」と言うまで気が付かなかったが、確かに
F と J の中心から、2cm くらい右に寄っている。見映えとしては、機械の中央
[- 日記システム警告:コマンド F は予約されています。-] についているので、これでいいのかも知れないが、使い勝手を犠性にしている と言われても止むを得ない設計の気がする。 それよりも、 鍵盤は何の為に上に行くほど段々左にずれていく配置になっているのでしょうね。 合理的に説明出来る人はきっとどこにもいない。 ( つっこみ )
#1 [Namazu] libintl.h not found, INCLUDES="-I/usr/local/include" ./configure12 21:35 env INCLUDES='/usr/local/include' ./configure 14 21:41 ./configure --include-directory=/usr/local 15 21:43 env LIBDIR='/usr/local' ./configure 17 21:46 rm config.cache ; env CFLAGS='-I/usr/local/include' ./configureいづれもだめですね。と言っても、以上は、configure の checking for libintl.h... no checking whether catgets can be used... no --omit-header: not found found xgettext program is not GNU xgettext; ignore itの部分だけで見ているので、実際に make した訳ではない。 きょう某所で jitterbug-1.6.2-i18n を組立てた時にも同じように libintl.h がないと言われた。多分 NetBSD 側の問題と考えた方が いいのかも知れない (もっとも jitterbug は全部が出来ているとこ ろに、jitterbug.c を少し変更して一部分だけ make したのも関係 しているかも知れない)。 いま念の為 makoto@harry ■22:05:20/000911(...src/namazu-2000-09-06)> \ env INCLUDES="-I/usr/local/include" ./configure makoto@harry ■22:06:14/000911(...src/namazu-2000-09-06)> time make をやって見たが、 gcc -DLOCALEDIR=\"/usr/local//locale\" -DOPT_CONFDIR=\"/usr/local/etc/namazu\" -DOPT_INDEXDIR=\"/usr/local/var/namazu/index\" -DHAVE_SUPPORT_H -DHAVE_CONFIG_H -I. -I.. -I./../lib -I./../src -I./../intl -I./../nmz -g -O2 -Wall -pedantic -c alias.c -fPIC -DPIC -o .libs/alias.lo In file included from alias.c:44: i18n.h:8: libintl.h: No such file or directory *** Error code 1やはりだめですね。 ( つっこみ )
|
最近の日記 2025年02月13日 ・dvipdfmx ICC profile format spec. version 4.3.0 2025年01月29日 ・ham/wsjtx 2025年01月27日 ・wip/wsjtx 5.4.2 2025年01月25日 ・ham/wsjtx 2025年01月15日 ・今更 advent calendar | ||