1.5.1/2 release
NetBSD/iBook
    More disk
  Machine Types
  Dual boot
  Versions
  Bootable CDROM
    Burning
    booting
Trial
Use Upgrade option
Preparation
  Partition (MacOS)
  NetBSD stuff on HFS
boot (netbsd.ram.gz)
  Open Firmware
  hfsboot
shell
  Getting Media
    CDROM
    Network
  disklabel wd0
  newfs
  mount
  tar
  pax
  replace kernel
  MAKEDEV
  /etc/fstab
Booting
  boot (Open Firmware)
  Permanent setup in OF
  /etc/rcconf
  Hot Keys
Other Sources
  links
  Error Messages
      netbsd: No such ..
      No response
      SIOCGIFFLAGS gm0: Device not ..
      TERM environment variable ..

tar

Now it's time to open *.tar.gz files onto the mounted partition.

sysinst use pax to open and write the tar.gz format files. That looks nice, but I have not used frequently, so I will show you the example with tar first,

cd /mnt
tar zxpf $MOUNT/binary/sets/base.tgz 
repeat for the rest of all the *.tgz files, or
Open everything at a time by:
cd /mnt
for i in $MOUNT/binary/sets/*.tgz 
  do echo $i
  tar zxpf $i
  done

pax

To use pax instead,
cd /mnt
for i in $MOUNT/binary/sets/*.tgz 
  do echo $i
  pax -zrpe -f $i
  done

replace kernel

Starting from 1.5V snapshot (20010517 or 20010524), you do NOT need to replace the kernel.

For iBook and PowerBook G3 Pismo users, you need to replace the kernel with ADB patch applied. See also versions page.
Precompiled kernel are listed below.
Copy one of those file onto /mnt, gunzip, and rename or (hard)link to /mnt/netbsd.

Locationnameremarks
ftp.ki.nu netbsd-1.5K-adb-insecure.gz 1.5K + adb patch, take 30 seconds to probe ADB, not recommended now.
ftp.ki.nu netbsd-1.5V-insecure.gz 1.5V "option INSECURE" enabled for XFree86
ftp.netbsd.org (1.5.1_BETA2) netbsd.GENERIC.gz1.5.1_BETA2
For example,
cd /mnt
mv netbsd netbsd-1.5S
cp $SOMEWHERE/netbsd-1.5V-insecure.gz .
gunzip netbsd-1.5V-insecure.gz 
ln netbsd-1.5V-insecure netbsd
I have heard there is a problem if the Permission missing +w bit, but I have not confirmed yet.
Last Update: Sat, 04 May 2019 00:45:20 GMT 1.66 2008/03/08