[an error occurred while processing this directive]
NetBSD/macppc 20021116
- preparation
-
-
cd /export
foreach i ( NetBSD-daily/current/200211140000/source/sets/*tgz )
echo $i
tar zxf $i
end
mkdir 20021116-ts
cd 20021116-ts
mv ../usr/src .
-
open ts version
cd src
tar zxf macppc-021116.tar.gz
-
Some changes are necessary outside of above tar file.
foreach i ( 20021116/?)
patch -s -p0 < $i
end
-
Machine with CUDA chip, like OF 1/2 machines, this needs for reading Real Time Clock correctly.
See toolchain PR:
PR/16678
patch -s -p0 < adb-20021109
-
/etc/mk.conf (see man mk.conf), may need following lines.
CWARNFLAGS+= -fno-strict-aliasing
TOOLCHAIN_MISSING=no
- build.sh
-
cd ..
setenv DESTDIR `pwd`/d
setenv RELEASEDIR `pwd`/r
cd src
time ./build.sh -D $DESTDIR -R $RELEASEDIR > & log-1
- completion
-
ttyp0:root@quick 9:34:57/021122(...20021116-ts/src)# time ./build.sh -D $DESTDIR -R $RELEASEDIR > & log-1
6393.410u 2056.050s 2:51:21.86 82.1% 0+0k 14668+404557io 14388pf+0w
- source/sets
-
setenv DESTDIR $FTP/pub/NetBSD/arch/macppc/snapshot/20021116ts/source/
makoto@quick (...20021116-ts/src)> mkdir -p $FTP/pub/NetBSD/arch/macppc/snapshot/20021116ts/source/
makoto@quick (...20021116-ts/src)> setenv SRCDIR `pwd`
makoto@quick (...20021116-ts/src)> sh distrib/sets/makesrctars
DESTDIR exists.
mkdir: $FTP/pub/NetBSD/arch/macppc/snapshot/20021116ts/source/sets: File exists
- status
-
- G4/400 (on ultra1:) stops after
starting=0x100000
line.
This is related to the fact that I am using long boot-file as
/pci@f2000000/@d/mac-io@7/ata-4@1f000/disk@1:10/netbsd
say, booting from ultra1, not ultra0 = hd. If the kernel placed on hd:, it works fine.
netatalk also works.
- iBook/SE 366 works fine
- G4/800 panics after mount root
root file system type: ffs
panic: cnopen: no console device
Stopped: pid 11(init) ...
See
more console info in Japanese
- amd client won't mount this kernel server if type:=host is on the map.
-
StarMax 3000/240
kernel works fine, but
netbsd.GENERIC_MD.gz traps (at a time)
at i/f setup inside sysinst.
Which device shall I use? [rtk0]: trap type 200 at 8b6978
Stopped in pid 29 (ifconfig) at 0x8b6978: sync
db> t
at 0x853b9c
at 0x8534a4
at 0x857d8c
at 0x852858
at 0x8b86e8
at 0x9dcf44
at 0x8b878c
at 0x9d0f54
at 0x99d6cc
at 0x99a0a4
at 0xa1cf00
at 0x801038
at 0x1857098
at 0x18546fc
at 0x1853f04
at 0x1853afc
at 0x18006a0
at 0x18002ec
at 0xfffffffc
db>
One more sysinst execution works fine. (?)
Wednesday, 12-Mar-2008 10:52:56 UTC
CCBot/2.0 (https://commoncrawl.org/faq/)
Apache/2.4.46 (Unix) PHP/7.4.15
(since 2002/11/11)