[an error occurred while processing this directive]

NetBSD/macppc 20030517

quick look:
mkdir 20030517ts
cd 20030517ts
cvs -d $CVS/CVSup/main co -D 20030516-UTC src > & co-20030516-UTC
cd src
tar zxf $BAR/macppc-030517.tar.gz
patch -s -p0 < $FOO/build.sh/20030210/1
patch -s -p0 < $FOO/build.sh/20030210/2
patch -s -p0 < $FOO/build.sh/20030210/4
patch -s -p0 < $FOO/build.sh/20030210/5
patch -s -p0 < $FOO/build.sh/20030210/7
patch -s -p0 < $FOO/build.sh/20030210/8
patch -s -p0 < $FOO/build.sh/adb-20021109
patch -s -p0 < $FOO/build.sh/config.bfd-20030420
patch -s -p0 < $FOO/build.sh/ffs_extern-20030527
cd ..
mkdir d r
setenv DESTDIR    `pwd`/d
setenv RELEASEDIR `pwd`/r
cd src
su
time ./build.sh -D $DESTDIR -R $RELEASEDIR release > & ../log-1
(Detail follows.)
preparation
  1. mkdir /export/20030517ts 
    cd    /export/20030517ts 
    cvs -d $CVS/CVSup/main co -D 20030516-UTC src
    
  2. cd src
    tar zxf macppc-030517.tar.gz
    
  3. Some changes are necessary outside of above tar file.
    foreach i ( 20030210/?)
       patch -s -p0 < $i
       end
    
  4. Machine with CUDA chip, like OF 1/2 machines, needs for reading Real Time Clock correctly. See toolchain PR: PR/16678
    patch -s -p0 <  adb-20021109
    
  5. patch -s -p0 < config.bfd-20030420

    You will got following message unless you apply this patch.

    /aa/src/tools/obj/tools.NetBSD-1.6R-powerpc/bin/powerpc--netbsd-objcopy -O xcoff-powermac -R .comment -R .note temp ofwboot.xcf
    /aa/src/tools/obj/tools.NetBSD-1.6R-powerpc/bin/powerpc--netbsd-objcopy: ofwboot.xcf: Invalid bfd target
  6. patch -s -p0 < ffs_extern-20030527

    Without this patch, you will get:

    Calculated size of `ramdisk.fs.tmp': 2097152 bytes, 287 inodes
    Extent size set to 4096
    ramdisk.fs.tmp: 2.0MB (4096 sectors) block size 4096, fragment size 512
            using 1 cylinder groups of 2.00MB, 512 blks, 320 inodes.
    super-block backups (for fsck -b #) at:
     32,nbmakefs: ffs_alloccg: map corrupted: start 2 len 510 offset 214 214
    
    Populating `ramdisk.fs.tmp'
    *** Error code 1
    
    Stop.
    nbmake: stopped in /export/20030516-utc/src/distrib/macppc/floppies/ramdisk
    
    Before applying above patch: makefs looks as follows
    ttyp0:makoto@serv  7:48:04/030529(...20030516-utc/src)> find tools usr.sbin  -name makefs -ls
    1109604      4 drwxr-xr-x    4 makoto            wheel                   512 May 18 23:20 tools/makefs
    1134836    224 -rwxr-xr-x    1 root              wheel                113645 May 18 23:49 tools/makefs/obj/makefs
     878198      4 drwxr-xr-x    5 makoto            wheel                   512 May 18 23:23 usr.sbin/makefs
    1225945    200 -rwxr-xr-x    1 root              wheel                100577 May 19 02:42 usr.sbin/makefs/obj/makefs
    
  7. some minor mod required for installboot.c, only for macppc-030517.tar.gz
    patch -s -p0 installboot-20030517
    
build.sh
cd ..
mkdir               d r
setenv DESTDIR      `pwd`/d
setenv RELEASEDIR   `pwd`/r
cd src
(su)
time ./build.sh -D $DESTDIR -R $RELEASEDIR release > & ../log-1
On some machine, it stops with following, on the other machine, won't.
/export/20030517ts/src/tools/obj/tools.NetBSD-1.6R-powerpc/bin/powerpc--netbsd-gcc -g -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wno-sign-compare -Wno-uninitialized -fno-strict-aliasing -fno-strict-aliasing -Werror -DINET6 -DHAVE_FUNCTION_MACRO=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBL=1 -DHAVE_LIBY=1 -DENABLE_IPV6=1 -DADVAPI=1 -DHAVE_GETADDRINFO=1 -DHAVE_GETNAMEINFO=1 -DSTDC_HEADERS=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDARG_H=1 -DHAVE_VARARGS_H=1 -DTIME_WITH_SYS_TIME=1 -DRETSIGTYPE=void -DHAVE_VPRINTF=1 -DHAVE_GETTIMEOFDAY=1 -DHAVE_SELECT=1 -DHAVE_SOCKET=1 -DHAVE_STRERROR=1 -DHAVE_STRTOL=1 -DHAVE_STRTOUL=1 -DHAVE_STRDUP=1 -DHAVE_GETIFADDRS=1 -DHAVE_ARC4RANDOM=1 -DHAVE_PFKEYV2 -DYIPS_DEBUG -DIPSEC -I. -I/export/20030517ts/src/crypto/dist/kame/racoon -Dss_family=__ss_family -Dss_len=__ss_len -DSYSCONFDIR=\"/etc/racoon\" -DHAVE_OPENSSL_OPENSSLV_H=1 -DYY_NO_UNPUT -I/export/20030517ts/src/crypto/dist/kame/libipsec -I/export/20030517ts/src/crypto/dist/kame/racoon/missing -DHAVE_GSSAPI -DRACOON_PKG_VERSION="\"netbsd-20021120\"" -I/export/20030517ts/src/dist/tcpdump -I/export/20030517ts/src/dist/tcpdump/lbl -DHAVE_PRINT_ISAKMP_C=1 -I/export/20030517ts/d/usr/include/krb5 -DHAVE_SIGNING_C=1 -DHAVE_OPENSSL_PEM_H=1 -DHAVE_OPENSSL_X509_H=1 -nostdinc -isystem /export/20030517ts/d/usr/include -c /export/20030517ts/src/crypto/dist/kame/racoon/isakmp.c
cc1: warnings being treated as errors
/export/20030517ts/src/crypto/dist/kame/racoon/isakmp.c: In function `isakmp_main':
/export/20030517ts/src/crypto/dist/kame/racoon/isakmp.c:363: warning: implicit declaration of function `racoon_free'
*** Error code 1

Stop.
nbmake: stopped in /export/20030517ts/src/usr.sbin/racoon/racoon
*** Error code 1
cvs update -r1.1 /export/20030517ts/src/crypto/dist/kame/racoon/sockmisc.c
Binaries are available at:
ftp://ftp.ki.nu/pub/NetBSD/arch/macppc/snapshot/20030517ts/
Problems:
sysinst won't do installboot successfully.
Wednesday, 12-Mar-2008 19:52:56 JST
Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; ClaudeBot/1.0; +claudebot@anthropic.com)
Apache/2.0.65 (Unix) mod_ssl/2.0.65 OpenSSL/1.0.1g DAV/2 PHP/5.4.26
Count.cgi
(since 2003/05/06)