[an error occurred while processing this directive]

NetBSD/macppc 20021214

preparation
  1.     mkdir /export/20021214-ts
        rmdir /usr/src
        ln -s /export/20021214-ts/src /usr/src
        cd /
        foreach i ( NetBSD-daily/current/200212130000/source/sets/*tgz )
          echo $i
          tar zxf $i
          end
        cd /export/20021214-ts
    
  2. open ts version
    cd src
    tar zxf macppc-021214.tar.gz
    
  3. Some changes are necessary outside of above tar file.
    foreach i ( 20021116/?)
       patch -s -p0 < $i
       end
    
  4. Machine with CUDA chip, like OF 1/2 machines, this needs for reading Real Time Clock correctly. See toolchain PR: PR/16678
    patch -s -p0 <  adb-20021109
    
  5. /etc/mk.conf (see man mk.conf), may need following lines.
    CWARNFLAGS+=   -fno-strict-aliasing
    TOOLCHAIN_MISSING=no
    
build.sh
cd ..
mkdir               d r
setenv DESTDIR      `pwd`/d
setenv RELEASEDIR   `pwd`/r
cd src
time ./build.sh -D $DESTDIR -R $RELEASEDIR > & ../log-1
completion
ttyp0:root@quick  21:09:17/021118(...20021214-ts/src)# time ./build.sh -D $DESTDIR -R $RELEASEDIR > & log-1
6868.674u 2370.422s 3:10:18.86 80.9%    0+0k 14477+454905io 16697pf+0w
(rtc is out of date)
source/sets
ttyp0:root@quick  0:19:40/021119(...20021214-ts/src)# setenv FTP /a/j/ftp
ttyp0:root@quick  21:04:37/021119(...20021214-ts/src)# setenv SRCDIR `pwd`
ttyp0:root@quick  21:04:47/021119(...20021214-ts/src)# setenv DESTDIR $FTP/pub/NetBSD/arch/macppc/snapshot/20021214ts/source
ttyp0:root@quick  21:05:05/021119(...20021214-ts/src)# mkdir $FTP/pub/NetBSD/arch/macppc/snapshot/20021214ts
ttyp0:root@quick  21:05:19/021119(...20021214-ts/src)# chown makoto \
chown makoto $FTP/pub/NetBSD/arch/macppc/snapshot/20021214ts
ttyp0:root@quick  21:05:25/021119(...20021214-ts/src)# sh distrib/sets/makesrctars
ttyp0:root@quick  21:17:32/021119(...20021214-ts/src)# 
(took about 12 mins)
copy binary/sets
ttyp0:makoto@quick  21:22:52/021119(...20021214-ts/r)> cp -pR . $FTP/pub/NetBSD/arch/macppc/snapshot/20021214ts
status
Unfortunately, the clock was set as Nov.18 arround at the build.sh time. It is the Dec. 2002 version, sorry.
0 > boot fd:0 |
>> NetBSD/macppc OpenFirmware Boot, Revision 1.5
>> (root@quick, Mon Nov 18 23:37:07 JST 2002)
3688156\
Above date shown is normal. Getting Following problem for OF 1/2
     Status: Failed: command failed
    Command: /usr/sbin/installboot /dev/rwd0a /usr/mdec/bootxx /boot
     Press any key to continue
--------------------------------------------------------------------------------
installboot: `/usr/mdec/bootxx' cannot be larger than 2048 bytes
installboot: Set bootstrap operation failed
 At a minimum, you should edit /etc/rc.conf to match your needs.  See
 /etc/defaults/rc.conf for the default values.


                           uid 0 comm sysinst on /: file system full
[1]   Segmentation fault      
# stty sane (not visible)
# ls -l /sysinst*
-r-xr-xr-x  59 root  wheel  1579000 Nov 18 15:15 sysinst
-rw-------   1 root  wheel    69632 Jan  1 17:20 sysinst.core
# df -k
Filesystem  1K-blocks     Used     Avail Capacity  Mounted on
/dev/md0a        1979     1777       202    89%    /
mfs:14           7903        1      7506     0%    /tmp
/dev/sd0a       49599    13930     33189    29%    /mnt
/dev/sd0g      197987    75184    112903    39%    /mnt/usr
# cd /mnt/usr
# cd /mnt/usr/mdec
# ./installboot -vh /mnt/boot bootxx /dev/rsd0a
installboot: unknown option -- h
usage: installboot [-n] [-v]   
# ./installboot -v /mnt/boot bootxx /dev/rsd0a
boot: /mnt/boot
proto: bootxx
device: /dev/rsd0a
proto bootblock size: 1024
entry point: 0x00600000
/mnt/boot: block numbers: 1664 1680 1696 1712 1728 1744 1760 1640 
# sync;sync;sync;reboot
...
0 > boot fd:0 ata/ata-disk@0:0/netbsd \
>> NetBSD/macppc OpenFirmware Boot, Revision 1.5
>> (root@quick, Mon Nov 18 23:37:07 JST 2002)
open ata/ata-disk@0:0/netbsd: Inappropriate file type or format
Boot: exit
EXIT called ok
Wednesday, 12-Mar-2008 19:52:56 JST
Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; ClaudeBot/1.0; +claudebot@anthropic.com)
Apache/2.0.65 (Unix) mod_ssl/2.0.65 OpenSSL/1.0.1g DAV/2 PHP/5.4.26
Count.cgi
(since 2002/12/17)